技術支持

交換機VLAN的締造與分別

發布時間:2019-03-15 08:14

 
 
我們之前曾提到關于vlan組網,但是還是有很多朋友反映:有沒有更加詳細、簡單直接的內容這次我們用一個實例來講解vlan的創建及組網過程,且所有的命令都有注釋,我們一起來看下。在了解vlan同時,我們也來簡單的了解下三層交換機。
 
 
 
一、為什么要選擇三層交換機

 
1、使用二層交換機+路由器進行VLAN間通信的問題
 
現在,我們知道只要能提供VLAN間路由,就能夠使分屬不同VLAN的計算機互相通信。
 
但是,如果使用路由器進行VLAN間路由的話,隨著VLAN之間流量的不斷增加,很可能導致路由器成為整個網絡的瓶頸。
 
交換機使用被稱為ASIC的專用硬件芯片處理數據幀的交換操作,在很多機型上都能實現纜線速度交換。而路由器,則基本上是基于軟件處理的。
 
就VLAN間路由而言,流量會集中到路由器和交換機互聯的匯聚鏈路部分,這一部分尤其特別容易成為速度瓶頸。
 
 
2、三層交換機
 
為了解決上述問題,三層交換機應運而生。三層交換機,本質上就是“帶有路由功能的(二層)交換機”。路由屬于OSI參照模型中第三層網絡層的功能,因此帶有第三層路由功能的交換機才被稱為“三層交換機”。
 
關于三層交換機的內部結構,可以參照下面的簡圖。
 
 
在一臺本體內,分別設置了交換機模塊和路由器模塊;而內置的路由模塊與交換模塊相同,使用ASIC硬件處理路由。因此,與傳統的路由器相比,可以實現高速路由。
 
 
 
二、vlan配置詳細教程實例


 
VLAN生成后交換機是互不相通的。因此,在交換機上設置VLAN后,如果未做其他處理,VLAN間是無法通信的。
 
為了使大家理解,我們用個實例來講解三層交換機的配置,實例不同vlan間進行通信,很詳細。
 
 
配置步驟如下:
 
1、S1三層交換機配置:

 
Switch>en  --進入特權模式
Switch#conf t  --進入全局配置模式
Switch(config)#hostname S1  --修改三層交換機主機名為S1
S1(config)#vtp domain test  --創建vtp域
Domain name already set to test.
S1(config)#vtp mode server  --設置當前交換機在vtp的工作模式為server
Device mode already VTP SERVER.
S1(config)#vlan 10  --創建vlan 10
S1(config-vlan)#vlan 20  --創建vlan 20
S1(config-vlan)#vlan 30  --創建vlan 30
 
S1(config-vlan)#vlan 40  --創建vlan40
S1(config-vlan)#interface f0/1  --進入端口
S1(config-if)#switchport mode access  --將端口模式改為access模式
S1(config-if)#switchport mode trunk  --將端口模式改為trunk模式
 
S1(config-if)#interface range f0/2-3  --進入端口
S1(config-if-range)#switchport mode access   --將端口模式改為access模式
S1(config-if-range)#switchport access vlan 40  --將端口劃入vlan 40
S1(config-if-range)#exit   --返回上一級
S1(config)#ip routing  --啟動三層交換機的路由功能
S1(config)#interface vlan 10  --進入vlan 10
S1(config-if)#ip address 192.168.1.254 255.255.255.0  --給vlan 10添加ip地址
S1(config-if)#interface vlan 20   --進入vlan 20
S1(config-if)#ip address 192.168.2.254 255.255.255.0  --給vlan 20添加ip地址
S1(config-if)#interface vlan 30  --進入vlan 30
S1(config-if)#ip address 192.168.3.254 255.255.255.0  --給vlan 30添加ip地址
S1(config-if)#interface vlan 40  --進入vlan 40
S1(config-if)#ip address 192.168.4.254 255.255.255.0  --給vlan 40添加ip地址
S1(config-if)#end  --返回特權模式
S1#copy running-config startup-config  --保存配置
 
[OK]  --保存成功
 
 
 
2、S2交換機配置
Switch>en  --進入特權模式
Switch#conf t  --進入全局配置模式
Switch(config)#hostname S2  --修改交換機名為S2
S2(config)#vtp mode client  --設置當前交換機在vtp中為客戶機模式
Device mode already VTP CLIENT.
S2(config)#interface f0/10  --進入端口
S2(config-if)#switchport mode trunk  --將端口設置為trunk模式
 
S2(config-if)#interface f0/1  --進入端口
S2(config-if)#switchport mode access  --將端口設置為access模式
S2(config-if)#switchport access vlan 30  --將端口劃入vlan30
S2(config-if)#interface f0/2  --進入端口
S2(config-if)#switchport mode access  --將端口設置為access模式
S2(config-if)#switchport access vlan 20  --將端口劃入vlan 20
S2(config-if)#interface f0/3  --進入端口
S2(config-if)#switchport mode access  --將端口設置為access模式
S2(config-if)#switchport access vlan 10  --將端口劃入vlan 10
S2(config-if)#end  --返回特權模式
S2#copy running-config startup-config  --保存配置
 
[OK]  --保存成功
 
 
 
3、S3交換機配置
Switch>en  --進入特權模式
Switch#conf t  --進入全局配置模式
Switch(config)#hostname S3  --修改交換機名為S3
S3(config)#vtp mode client  --設置當前交換機在vtp中為客戶模式
Device mode already VTP CLIENT.
S3(config)#interface range f0/10-12  --進入端口
S3(config-if-range)#switchport mode trunk  --將端口設置為trunk模式
 
S3(config-if-range)#interface f0/1  --進入端口
S3(config-if)#switchport mode access  --將端口設置為access模式
S3(config-if)#switchport access vlan 30  --將端口劃入vlan 30
S3(config-if)#interface f0/2  --進入端口
S3(config-if)#switchport mode access   --將端口設置為access模式
S3(config-if)#switchport access vlan 20  --將端口劃入vlan20
S3(config-if)#interface f0/3  --進入端口
S3(config-if)#switchport mode access  --將端口設置為access模式
S3(config-if)#switchport access vlan 10  --將端口劃入vlan 20
S3(config-if)#end  --返回特權模式
S3#copy running-config startup-config  --保存配置
 
[OK]  --保存成功
 
 
 
4、S4交換機配置
Switch>en  --進入特權模式
Switch#conf t  --進入全局配置模式
Switch(config)#hostname S4  --修改交換機名為S4
S4(config)#vtp mode client  --設置當前交換機在vtp中為客戶模式
S4(config)#interface f0/10  --進入端口
S4(config-if)#switchport mode trunk  --將端口設置為trunk模式
S4(config-if)#interface f0/1  --進入端口
S4(config-if)#switchport mode access  --將端口設置為access模式
S4(config-if)#switchport access vlan 30  --將端口劃入vlan 30
S4(config-if)#interface f0/2  --進入端口
S4(config-if)#switchport mode access  --將端口設置為access模式
S4(config-if)#switchport access vlan 20  --將端口劃入vlan 20
S4(config-if)#interface f0/3  --進入端口
S4(config-if)#switchport mode access  --將端口設置為access模式
S4(config-if)#switchport access vlan 10  --將端口劃入vlan 10
S4(config-if)#end  --返回特權模式
S4#copy running-config startup-config  --保存配置
 
[OK]  --保存成功
 
 
 
 
三、驗證
 
測試不同vlan下的主機是否互通。
 
1、PC11與PC33
 
 
 
vlan10與vlan30互通
 
 
 
2、PC13與PC21
 
 
 
vlan10與vlan20互通。


以上就是關于交換機VLAN的締造與分別的相關資訊,了解更多內容請關注信安網絡科技有限公司

大众麻将怎么算赢